Home
Snapcenter Plugin for VMWare 4.5 incompatible with vCenter 7.0.3
VMWare (Netapp) Tuesday, 12 October 2021 by paul

After upgrading vCenter to 7.0 Update 3 then Snapcenter Plugin for VMware fails to load with the following error:

Error deploying plug-in. org.apache.felix.resolver.reason.ReasonException: Unable to resolve /usr/lib/vmware-vsphere-ui/server/work/tmp/2150534555311644163com.netapp.scvm.webclient-4.5.0.6025788.esa/scvm_webui_service.jar: missing requirement org.apache.aries.subsystem.core.archive.ImportPackageRequirement: namespace=osgi.wiring.package, attributes={}, directives={filter=(&(osgi.wiring.package=org.springframework.web.servlet.view.velocity)(version>=0.0.0)), resolution=mandatory, uses=javax.servlet,javax.servlet.http,org.apache.velocity,org.apache.velocity.app,org.apache.velocity.context,org.apache.velocity.exception,org.apache.velocity.tools.generic,org.springframework.beans,org.springframework.beans.factory,org.springframework.context,org.springframework.ui.velocity,org.springframework.web.context,org.springframework.web.servlet.view}, resource=/usr/lib/vmware-vsphere-ui/server/work/tmp/2150534555311644163com.netapp.scvm.webclient-4.5.0.6025788.esa/scvm_webui_service.jar org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1340) org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:433) org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:420) org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:413) org.apache.aries.subsystem.core.internal.SubsystemResource.computeDependencies(SubsystemResource.java:393) org.apache.aries.subsystem.core.internal.SubsystemResource.computeDependencies(SubsystemResource.java:363) org.apache.aries.subsystem.core.internal.SubsystemResource.<init>(SubsystemResource.java:101) org.apache.aries.subsystem.core.internal.SubsystemResource.<init>(SubsystemResource.java:91) org.apache.aries.subsystem.core.internal.InstallAction.run(InstallAction.java:60) org.apache.aries.subsystem.core.internal.InstallAction.run(InstallAction.java:27) java.security.AccessController.doPrivileged(Native Method) org.apache.aries.subsystem.core.internal.BasicSubsystem.install(BasicSubsystem.java:677) org.apache.aries.subsystem.core.internal.BasicSubsystem.install(BasicSubsystem.java:730) org.apache.aries.subsystem.core.internal.BasicSubsystem.install(BasicSubsystem.java:304) org.apache.aries.subsystem.core.internal.BasicSubsystem.install(BasicSubsystem.java:299) org.apache.aries.subsystem.core.internal.BasicSubsystem.install(BasicSubsystem.java:71) com.vmware.vise.extensionfw.impl.OsgiBundleDeployer$SubsystemInstallerTask.run(OsgiBundleDeployer.java:706) java.lang.Thread.run(Thread.java:748)

This is due to SCV 4.x not yet being compatible with vCenter 7.0 Update 3. It will be compatible in SCV 4.6 which is currently in development.

The fix is to downgrade vCenter or replace some of the plugin files, on the vCenter server, which updated versions available at the following link:

https://kb.netapp.com/Advice_and_Troubleshooting/Data_Protection_and_Security/SnapCenter/After_upgrade_of_vCenter_Server_7.0_update_3_the_SCV_can_not_be_deployed

 


Add Comment
Thursday, 28 October 2021 by Stefan
helped and running. Thanks